[RESOLVED] Reports of issues accessing Webflow.com

Incident Report for Webflow

Resolved

We’re no longer seeing customer impact related to this issue, and access to Webflow services has returned to normal. Some customers experienced issues accessing Webflow between 15:15 UTC and 15:37 UTC. This incident is now resolved.
We appreciate your patience while our team worked to restore normal functionality.

Affected Components:
Dashboard → Operational
Webflow Canvas → Operational
Webflow.com → Operational
Posted May 20, 2026 - 15:00 UTC